雪域.蒼狼 / 股票原程序 / 自調MACD

   

自調MACD

2012-05-11  雪域.蒼狼

自調MACD

(2012-02-09 08:50:56)
標簽:

股票

分類: 大智慧指標源碼

自調MACD

 

INPUT:SHORT(12,1,100),LONG(26,2,100),M(9,1,50),T(0,0,2);
DIFF:=EMA(C,SHORT)-EMA(C,LONG);
DEA:=EMA(DIFF,M);MACD:=2*(DIFF-DEA);
日DIF:IF(T=0,DIFF,0),PRECIS2,LAYER0,ColorRED;
日DEA:IF(T=0,DEA,0),PRECIS2,LAYER0,ColorA8A818;
MACD:2*(DIFF-DEA),Color283898,LINETHICK0;
ZDIF:="MACD.DIFF#WEEK"(12,26,9);  ZDEA:="MACD.DEA#WEEK"(12,26,9);
YDIF:="MACD.DIFF#MONTH"(12,26,9); YDEA:="MACD.DEA#MONTH"(12,26,9);
STICKLINE(MACD>0 AND MACD>REF(MACD,1),0,MACD,0,0),Color282888;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),0,MACD,0,1),Color505018;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),0,MACD,0,0),Color083908;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),0,MACD,0,1),Color503350;
周DIF:IF(T=1,ZDIF,0),PRECIS2,LAYER0,Color189898;
周DEA:IF(T=1,ZDEA,0),PRECIS2,LAYER0,Color188818;
月DIF:IF(T=2,YDIF,0),PRECIS2,LAYER0,Color983898;
月DEA:IF(T=2,YDEA,0),PRECIS2,LAYER0,Color688868;

    本站是提供個人知識管理的網絡存儲空間,所有內容均由用戶發布,不代表本站觀點。如發現有害或侵權內容,請點擊這里 或 撥打24小時舉報電話:4000070609 與我們聯系。

    0條評論

    發表

    請遵守用戶 評論公約

    類似文章 更多
    喜歡該文的人也喜歡 更多

    ×
    ×

    .00

    微信或支付寶掃碼支付:

    《個圖VIP服務協議》

    全部>>
    电竞竞猜app